-
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) Why is this conditional on cursor position now?
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) I think better approach here would be to use continue, and eliminate the check after the switch statement. As this logic stands now, its harder to follow the flow.
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) Are these
tem.*
properties documented anywhere?
10234 uts: early start frame buffer console support
Review Request #1366 — Created Jan. 14, 2019 and submitted
Information | |
---|---|
tsoome | |
illumos-gate | |
10234 | |
1367, 1368 | |
484c1a8... | |
Reviewers | |
general | |
uts: implement env module support and use data from boot loader uts: vgareg.h update and remove boot_vga.h uts: do not reset serial console uts: identify FB types
-
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) Is there a reason these aren't in a header file?
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) Any reason we're not using VGA_TEXT_ROWS and VGA_TEXT_COLS for this? As I assume that's what we're basing it on.
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) I assume the removal here is for the same reason as in the console case above?
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revision 1) common/util/strtoul seems like it's already been built to handle building in this environment.
-
-
-
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) If we have a height or width that are unsigned, these could become negative when casting them to shorts.
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) Do we have something guaranteeing elsewhere that we won't have a bad value passed here that'll cause us to end up in the default case? It may make sense to actually use an enum to represent the values so it's easier to know if we've missed a case.
-
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) What makes sure that we don't index into these array beyond their bounds?
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) Why do we only want to do this if console is CONS_FRAMEBUFFER?
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) Arrow keys work for me in kmdb on the serial console today. Which case are you referring to here?
-
-
-
usr/src/uts/i86pc/boot/boot_fb.c (Diff revision 1) Just to confirm, width here is in uint32_t units right? It's not a number of bytes, but a number of logical cells wide.
-
usr/src/uts/i86pc/boot/boot_vga.c (Diff revision 1) Are the inb's here that we're ignoring the data from trying to act as a flush to make sure the status is up to date?
-
usr/src/uts/i86pc/dboot/dboot_startkern.c (Diff revision 1) Is this why we're allocating two of them? Is there a reason we're not asking the compiler to align that variable?
-
usr/src/uts/i86pc/sys/framebuffer.h (Diff revision 1) Is there a reason that we're using a uint32_t for what I think is basically tracking a boolean? It's fine, just a bit surprising.
-
-
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 2 (+1223 -132) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 3 (+1223 -132) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 4 (+1256 -135) |
-
Thanks for the clean up, this generally looks good.
-
usr/src/uts/i86pc/boot/boot_console.c (Diff revisions 1 - 4) Will we remove the _NEWFONT definition once that work comes in? Is this a temporary ifdef?
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 5 (+1256 -135) |
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 6 (+1223 -132) |
Change Summary:
overflow check backported from 10235, + small optimization for loop condition.
Commit: |
|
||||
---|---|---|---|---|---|
Diff: |
Revision 7 (+1225 -132) |