USB_STRING_DESCR(9S) Data Structures for Drivers USB_STRING_DESCR(9S)


NAME


usb_string_descr - USB string descriptor

SYNOPSIS


#include <sys/usb/usba.h>


INTERFACE LEVEL


illumos DDI specific (illumos DDI)

DESCRIPTION


The usb_string_descr_t string descriptor defines the attributes of a
string, including size and Unicode language ID. Other USB descriptors
may have string descriptor index fields which refer to specific string
descriptors retrieved as part of a device's configuration.


Please refer to Section 9.6.7 of the USB 2.0 specification. The USB 2.0
specification is available at www.usb.org.


A string descriptor has the following fields:

uint8_t bLength Size of this descriptor,
in bytes.

uint8_t bDescriptorType Set to USB_DESCR_TYPE_STRING.

uint16_t bString[1]; Variable length Unicode encoded
string.


ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-------------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-------------------+
|Architecture | PCI-based systems |
+--------------------+-------------------+
|Interface stability | Committed |
+--------------------+-------------------+

SEE ALSO


attributes(7), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F),
usb_get_string_descr(9F), usb_parse_data(9F), usb_ctrl_request(9S)


January 5, 2004 USB_STRING_DESCR(9S)