NET_INSTANCE_T(9S) Data Structures for Drivers NET_INSTANCE_T(9S)


NAME


net_instance_t - packet event structure passed through to hooks

SYNOPSIS


#include <sys/neti.h>


INTERFACE LEVEL


illumos DDI specific (illumos DDI).

DESCRIPTION


The net_instance_t data structure defines a collection of instances to be
called when relevant events happen within IP. The value returned by the
nin_create() function is stored internally and passed back to both the
nin_destroy() and nin_shutdown() functions as the second argument. The
netid_t passed through to each function can be used to uniquely identify
each instance of IP.

STRUCTURE MEMBERS


char *nin_name;
void *(*nin_create)(const netid_t);
void (*nin_destroy)(const netid_t, void *);
void (*nin_shutdown)(const netid_t, void *);


nin_name
Name of the owner of the instance.


nin_create
Function to be called when a new instance of IP is
created. It may not return NULL.


nin_destroy
Function to be called when an instance of IP is being
destroyed.


nin_shutdown
Function to be called when an instance of IP is being
shutdown. nin_shutdown() is called before nin_destroy()
is called.


ATTRIBUTES


See attributes(7) for descriptions of the following attributes:


+--------------------+-----------------+
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
+--------------------+-----------------+
|Interface Stability | Committed |
+--------------------+-----------------+

SEE ALSO


attributes(7), netinfo(9F)


March 5, 2012 NET_INSTANCE_T(9S)