IPADM(8) Maintenance Procedures IPADM(8)
NAME
ipadm - configure IP and IPMP interfaces, addresses and protocols
SYNOPSIS
ipadm help ipadm create-if [
-t]
interface ipadm create-ip [
-t]
interface ipadm delete-if interface ipadm delete-ip interface ipadm create-ipmp [
-t] [
-i interface[,
interface]...]
ipmp-interface ipadm delete-ipmp ipmp-interface ipadm add-ipmp [
-t]
-i interface[,
interface]...
ipmp-interface ipadm remove-ipmp [
-t]
-i interface[,
interface]...
ipmp-interface ipadm disable-if -t interface ipadm enable-if -t interface ipadm show-if [[
-p]
-o field[,
field]...] [
interface]
ipadm set-ifprop [
-t]
-p prop=
value[,
value]...
-m protocol interface ipadm reset-ifprop [
-t]
-p prop -m protocol interface ipadm show-ifprop [[
-c]
-o field[,
value]...] [
-p prop[,
prop]...]
[
-m protocol] [
interface]
ipadm create-addr [
-t]
-T static [
-d]
-a [
local|
remote=]
addr[/
prefixlen]...
addrobj ipadm create-addr [
-t]
-T dhcp [
-1] [
-h hostname] [
-w {
seconds|
forever}]
addrobj ipadm create-addr [
-t]
-T addrconf [
-i interface-id]
[
-p {
stateful|
stateless}={
yes|
no}]...
addrobj ipadm delete-addr [
-r]
addrobj ipadm show-addr [[
-p]
-o field[,
field]...] [
addrobj]
ipadm refresh-addr [
-i]
addrobj ipadm down-addr [
-t]
addrobj ipadm up-addr [
-t]
addrobj ipadm disable-addr [
-t]
addrobj ipadm enable-addr [
-t]
addrobj ipadm set-addrprop [
-t]
-p prop=
value[,
value]...
addrobj ipadm reset-addrprop [
-t]
-p prop addrobj ipadm show-addrprop [[
-c]
-o field[,
field]...] [
-p prop[,
prop]...]
[
addrobj]
ipadm set-prop [
-t]
-p prop[
+|
-]=
value[,
value]...
protocol ipadm reset-prop [
-t]
-p prop protocol ipadm show-prop [[
-c]
-o field[,
field]...] [
-p prop[,
prop]...] [
protocol]
DESCRIPTION
The
ipadm command is a stable replacement for the
ifconfig(8) and
ndd(8) commands. It is used to create IP interfaces and to configure IP addresses
on those interfaces. It is also used to get, set or reset properties on
interfaces, addresses and protocols.
For subcommands that take an
addrobj, the
addrobj specifies a unique
address on the system. It is made up of two parts, delimited by a `/'.
The first part is the name of the interface and the second part is a string
up to 32 characters long. For example, "lo0/v4" is a loopback interface
addrobj name.
For subcommands that take a
protocol, this can be one of the following
values:
ip,
ipv4,
ipv6,
icmp,
tcp,
sctp or
udp.
SUBCOMMANDS
When invoked with no arguments,
ipadm shows the current address properties,
in the same way as
ipadm show-addr.
The following subcommands are supported:
ipadm help Display brief command usage.
ipadm create-if [
-t]
interface ipadm create-ip [
-t]
interface Create an IP interface that will handle both IPv4 and IPv6 packets.
The interface will be enabled as part of the creation process. The
IPv4 interface will have the address 0.0.0.0. The IPv6 interface
will have the address ::. The subcommands
create-if and
create-ip are functionally equivalent aliases of each other.
-t,
--temporary Temporary, not persistent across reboots.
ipadm delete-if interface ipadm delete-ip interface Permanently delete the specified IP interface. The subcommands
delete-if and
delete-ip are functionally equivalent aliases of each
other.
ipadm create-ipmp [
-t] [
-i interface[,
interface]...]
ipmp-interface Create an IPMP interface that will handle both IPv4 and IPv6
packets. The interface will be enabled as part of the creation
process. The IPv4 interface will have the address 0.0.0.0. The
IPv6 interface will have the address ::.
-i,
--interface Interface(s) to be added to the new IPMP interface.
-t,
--temporary Temporary, not persistent across reboots.
ipadm delete-ipmp ipmp-interface Permanently delete the IPMP interface.
ipadm add-ipmp [
-t]
-i interface[,
interface]...
ipmp-interface Add the IP interface(s) to the IPMP interface.
-i,
--interface Interface(s) to be added to the IPMP interface.
-t,
--temporary Temporary, not persistent across reboots.
ipadm remove-ipmp [
-t]
-i interface[,
interface]...
ipmp-interface Remove the IP interface(s) from the IPMP interface.
-i,
--interface Interface(s) to be removed from the IPMP interface.
-t,
--temporary Temporary, not persistent across reboots.
ipadm disable-if -t interface Disable the specified IP interface.
-t,
--temporary Temporary, not persistent across reboots.
ipadm enable-if -t interface Enable the specified IP interface.
-t,
--temporary Temporary, not persistent across reboots.
ipadm show-if [[
-p]
-o field[,
field]...] [
interface]
Show the current IP interface configuration.
-o,
--output Select which fields will be shown. The field value can be
one of the following names:
ALL Display all fields.
IFNAME The name of the interface.
STATE The state can be one of the following values:
ok resources for the interface have been
allocated
offline the interface is offline
failed the interface's datalink is down
down the interface is down
disabled the interface is disabled
CURRENT A set of single character flags indicating the
following:
b broadcast (mutually exclusive with `p')
m multicast
p point-to-point (mutually exclusive with `b')
v virtual interface
I IPMP
s IPMP standby
i IPMP inactive
V VRRP
a VRRP accept mode
4 IPv4
6 IPv6
PERSISTENT A set of single character flags showing what
configuration will be used the next time the
interface is enabled:
s IPMP standby
4 IPv4
6 IPv6
-p,
--parsable Print the output in a parsable format.
ipadm set-ifprop [
-t]
-p prop=
value[,
value]...
-m protocol interface Set a property's value(s) on the specified IP interface.
-m,
--module Specify which protocol the setting applies to.
-p,
--prop Specify the property name and value(s). The property name
can be one of the following:
arp Address resolution protocol (
on/
off).
exchange_routes Exchange of routing data (
on/
off).
forwarding IP Forwarding (
on/
off)
metric Set the routing metric to the numeric
value. The value is treated as extra hops
to the destination.
mtu Set the maximum transmission unit to the
numeric value.
nud Neighbor unreachability detection (
on/
off)
usesrc Indicates which interface to use for
source address selection. A value
none may also be used.
-t,
--temporary Temporary, not persistent across reboots.
ipadm reset-ifprop [
-t]
-p prop -m protocol interface Reset the specified IP interface's property value to the default.
-m,
--module Specify which protocol the setting applies to.
-p,
--prop Specify the property name. See the
ipadm set-ifprop subcommand for the list of property names.
-t,
--temporary Temporary, not persistent across reboots.
ipadm show-ifprop [[
-c]
-o field[,
value]...] [
-p prop[,
prop]...] [
-m protocol] [
interface]
Display the property values for one or all of the IP interfaces.
-c,
--parsable Print the output in a parsable format.
-m,
--module Specify which protocol to display.
-o,
--output Select which fields will be shown. The field value can be
one of the following names:
ALL Display all fields.
IFNAME The name of the interface.
PROPERTY The name of the property.
PROTO The name of the protocol.
PERM If the property is readable ("r") and/or
writable ("w").
CURRENT The value of the property.
PERSISTENT The persistent value of the property.
DEFAULT The default value of the property.
POSSIBLE The possible values for the property.
-p,
--prop Specify which properties to display. See the
ipadm set-ifprop subcommand for the list of property names.
ipadm create-addr [
-t]
-T static [
-d]
-a [
local|
remote=]
addr[/
prefixlen]...
addrobj Create an address on the specified IP interface using static
configuration. The address will be enabled but can disabled using
the
ipadm disable-addr subcommand. Note that
addrconf address
configured on the interface is required to configure
static IPv6
address on the same interface. This takes the following options:
-a,
--address Specify the address. The
local or
remote prefix can be
used for a point-to-point interface. In this case, both
addresses must be given. Otherwise, the equal sign ("=")
should be omitted and the address should be provided by
itself without second address.
-d,
--down The address is down.
-t,
--temporary Temporary, not persistent across reboots.
ipadm create-addr [
-t]
-T dhcp [
-1] [
-h hostname] [
-w {
seconds|
forever}]
addrobj Create an address on the specified IP interface using DHCP. This
takes the following options:
-1,
--primary Specify that the interface is primary. One effect will be
that
nodename(5) will serve as
-h,
--reqhost if that switch
is not otherwise specified.
-h,
--reqhost Specify the host name to send to the DHCP server in order
to request an association of a Fully Qualified Domain Name
to the interface. An FQDN is determined from
hostname if
it is "rooted" (ending in a '.'), or if it consists of at
least three DNS labels, or by appending to
hostname the DNS
domain name value configured in
/etc/default/dhcpagent for
dhcpagent(8). N.b. that the DHCP server implementation
ultimately determines whether and how the client-sent FQDN
is used.
-t,
--temporary Temporary, not persistent across reboots.
-w,
--wait Specify the time, in seconds, that the command should wait
to obtain an address; or specify
forever to wait without
interruption. The default value is 120.
ipadm create-addr [
-t]
-T addrconf [
-i interface-id] [
-p {
stateful|
stateless}={
yes|
no}]...
addrobj Create an auto-configured address on the specified IP interface.
This takes the following options:
-i,
--interface-id Specify the interface ID to be used.
-p,
--prop Specify which method of auto-configuration should be used.
-t,
--temporary Temporary, not persistent across reboots.
ipadm delete-addr [
-r]
addrobj Delete the given address.
-r,
--release Indicate that the DHCP-assigned address should be released.
ipadm show-addr [[
-p]
-o field[,
field]...] [
addrobj]
Show the current address properties.
-o,
--output Select which fields will be shown. The field value can be
one of the following names:
ALL Display all fields.
ADDROBJ The name of the address.
TYPE The type of the address (
static/
dhcp/
addrconf).
STATE The state of the address. It can be one of the
following values:
disabled see the
ipadm disable-addr subcommand
down see the
ipadm down-addr subcommand
duplicate the address is duplicate
inaccessible the interface for this address
has failed
ok the address is up
tentative duplicate address detection in
progress
CURRENT A set of single character flags indicating the
following:
U up
u unnumbered (matches another local address)
p private, not advertised to routing
t temporary IPv6 address
d deprecated (not used for outgoing packets)
PERSISTENT A set of single character flags showing the
configuration which will be used when the
address is enabled.
U up
p private, not advertised to routing
d deprecated (not used for outgoing packets)
ADDR The address.
-p,
--parsable Print the output in a parsable format.
ipadm refresh-addr [
-i]
addrobj Extend the lease for
DHCP addresses. It also restarts duplicate
address detection for
static addresses.
-i,
--inform Obtain network configuration from DHCP without taking a lease on
the address.
ipadm down-addr [
-t]
addrobj Down the address. This will stop packets from being sent or
received.
-t,
--temporary Temporary, not persistent across reboots.
ipadm up-addr [
-t]
addrobj Up the address. This will enable packets to be sent and received.
-t,
--temporary Temporary, not persistent across reboots.
ipadm disable-addr [
-t]
addrobj Disable the address.
-t,
--temporary Temporary, not persistent across reboots.
ipadm enable-addr [
-t]
addrobj Enable the address.
-t,
--temporary Temporary, not persistent across reboots.
ipadm set-addrprop [
-t]
-p prop=
value[,
value]...
addrobj Set a property's value(s) on the addrobj.
-p,
--prop Specify the property name and value(s). The property name
can be one of the following:
broadcast The broadcast address (read-only).
deprecated The address should not be used to send packets
but can still receive packets (
on/
off).
prefixlen The number of bits in the IPv4 netmask or IPv6
prefix.
primary The DHCP primary interface flag (read-only).
private The address is not advertised to routing
(
on/
off).
reqhost The host name to send to the DHCP server in
order to request an association of the FQDN to
the interface. For a primary DHCP interface,
nodename(5) is sent if this property is not
defined. See the
ipadm create-addr -T dhcp subcommand for the explanation of how an FQDN
is determined.
transmit Packets can be transmitted (
on/
off).
zone The zone the addrobj is in (temporary-only--use
zonecfg(8) to make persistent).
-t,
--temporary Temporary, not persistent across reboots.
ipadm reset-addrprop [
-t]
-p prop addrobj Reset the addrobj's property value to the default.
-p,
--prop Specify the property name. See the
ipadm set-addrprop subcommand for the list of property names.
-t,
--temporary Temporary, not persistent across reboots.
ipadm show-addrprop [[
-c]
-o field[,
field]...] [
-p prop[,
prop]...]
[
addrobj]
Display the property values for one or all of the addrobjs.
-c,
--parsable Print the output in a parsable format.
-o,
--output Select which fields will be shown. The field value can be
one of the following names:
ALL Display all fields.
ADDROBJ The name of the addrobj.
PROPERTY The name of the property.
PERM If the property is readable ("r") and/or
writable ("w").
CURRENT The value of the property.
PERSISTENT The persistent value of the property.
DEFAULT The default value of the property.
POSSIBLE The possible values for the property.
-p,
--prop Specify which properties to display. See the
ipadm set-addrprop subcommand for the list of property names.
ipadm set-prop [
-t]
-p prop[
+|
-]=
value[,
value]...
protocol Set a property's value(s) on the protocol.
-p,
--prop Specify the property name and value(s). The optional
+|
- syntax can be used to add/remove values from the current
list of values on the property. The property name can be
one of the following:
congestion_control The default congestion-control
algorithm to be used for new
connections (TCP).
ecn Explicit congestion control
(
never/
passive/
active) (TCP).
extra_priv_ports Additional privileged ports
(SCTP/TCP/UDP).
forwarding Packet forwarding (
on/
off).
hoplimit The IPv6 hoplimit.
hostmodel IP packet handling on multi-homed
systems (
weak/
strong/
src-priority)
(IPv4/IPv6).
weak and
strong correspond to the model definitions
defined in RFC 1122.
src-priority is a hybrid mode where outbound
packets are sent from the interface
with the packet's source address if
possible.
largest_anon_port Largest ephemeral port
(SCTP/TCP/UDP).
max_buf Maximum receive or send buffer size
(ICMP/SCTP/TCP/UDP). This also sets
the upper limit for the
recv_buf and
send_buf properties.
recv_buf Default receive buffer size
(ICMP/SCTP/TCP/UDP). The maximum
value for this property is
controlled by the
max_buf property.
sack Selective acknowledgement
(
active/
passive/
never) (TCP).
send_buf Default send buffer size
(ICMP/SCTP/TCP/UDP). The maximum
value for this property is
controlled by the
max_buf property.
smallest_anon_port Smallest ephemeral port
(SCTP/TCP/UDP).
smallest_nonpriv_port Smallest non-privileged port
(SCTP/TCP/UDP).
ttl The IPv4 time-to-live.
-t,
--temporary Temporary, not persistent across reboots.
ipadm reset-prop [
-t]
-p prop protocol Reset a protocol's property value to the default.
-p,
--prop Specify the property name. See the
ipadm set-prop subcommand for the list of property names.
-t,
--temporary Temporary, not persistent across reboots.
ipadm show-prop [[
-c]
-o field[,
field]...] [
-p prop[,
prop]...] [
protocol]
Display the property values for one or all of the protocols.
-c,
--parsable Print the output in a parsable format.
-o,
--output Select which fields will be shown. The field value can be
one of the following names:
ALL Display all fields.
PROTO The name of the protocol.
PROPERTY The name of the property.
PERM If the property is readable ("r") and/or
writable ("w").
CURRENT The value of the property.
PERSISTENT The persistent value of the property.
DEFAULT The default value of the property.
POSSIBLE The possible values for the property.
-p,
--prop Specify which properties to display. See the
ipadm set-prop subcommand for the list of property names.
SEE ALSO
nodename(5),
nsswitch.conf(5),
dhcp(7),
arp(8),
cfgadm(8),
dhcpagent(8),
dladm(8),
if_mpadm(8),
ifconfig(8),
ndd(8),
zonecfg(8)OmniOS November 15, 2021 OmniOS